読者です 読者をやめる 読者になる 読者になる

mikutter blog

mikutterのアナウンスなど

#mikutter 0.0.4, 0.1.0 rev.571

  • 0.0.4
    • コンソールから実行するRubyスクリプトにフッダがつく
    • URL再帰展開が上手く動かなくなっていた
    • SubpartsVoterのレンダリングの最適化
    • プラグイン独自の設定画面を提供するための新しいAPIを提供
      • ドキュメントは近々
    • 稀にクリックしても開けないURLがあった
  • 0.1
    • 次回バージョンを0.1としました
先週、風邪でリリース出来なかったので、今やっちゃいます。
trunkのバージョンを0.1にしました。それに伴い0.0.4のbranchを作成して、不安定版としてリリースします。

0.0.4は、Ruby1.8では警告が出て普通には起動できません。実用に耐えるほどのレスポンスが担保できないためです。
また、0.1では、Ruby1.9の機能を積極的に使って行きます。なので、今後0.1をruby1.8で使うと、Syntax Errorとかで起動しないと思います、多分。どうしてもRuby1.8で使いたい人は、0.0.3を使ってください。ubuntuならはやく11.10にうpgらですればいいと思いますの。

0.0.3は、よほど深刻なバグがない限りコミットしません。何かあれば開発者に教えてください。

Ruby1.9.3おめでとうございます。
mikutterも、Ruby1.9.3を積極的に使っていきたいと考えています。動作報告もあるので、暇な人はアップグレードしたら面白いかも知れません。